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User Guide for ZSOM™-MO01 Start Kit

Enabling Advanced Commercial-Off-The-Shelf (COTS) to ‘Space-Grade’

ZES400 Pins Microcontroller Pins
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Summary
ZSOM™-MOL1 is a radiation-tolerant system-on- = Proprietary error-detection-and-correction
module (SOM) embodying an ARM Cortex-MO+ (EDAC) C-code for detecting/correcting
microcontroller and ZES proprietary radiation- multiple errors in SRAMs/FRAMs within the
hardened technology for mitigating Single-Event- ARM Cortex-M0O+ microcontroller
Latchup (SEL) and Single-Event-Upset (SEU) in * High Reliability Manufacturing PCB (Class ll)
irradiation environments. It can be configured = Arduino-Compatible Integrated Design
within the Arduino-Compatible platform, leveraging Environment (IDE)
available open-source code. ZSOM™-M01 »  Proton test up to 200MeV @ fluence > 101
enables a quick and reliable payload development particles/cm?
platform for space-based applications. * Total lonizing Dose (TID) (to be available
soon)
Key Features
= Low power embedded microcontroller-based Applications
SOM with SEL protection and SEU protection
= SEL protection enabled by ZES100 Radiation- = Low power embedded applications forpayloads
Hardened Latchup Detection and Protection suitable for Low-Earth-Orbit (LEO)
(LDAP) chip =  Watch-dog application
= External FRAM with SEU protection in Triple- = Data communication applications

Modular-Redundancy (TMR): enabled by
ZES400 Radiation-Hardened Voters
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1 Overview

ZSOM™-MO01 is a radiation-tolerant system-on-module (SOM) embodying an ARM Cortex-MO0+
microcontroller, a Triple-Modular-Redundancy (TMR) 256kB FRAM with a ZES400 radiation hardened voter,
a ZES proprietary ZES100 Latchup Detection and Protection (LDAP) chip, and a DC/DC converter.
ZSOM™-MO01 can be configured within an Arduino-Compatible platform, leveraging the growing list of open-
source code available for space-based applications. ZSOM™-MO01 provides a quick and reliable payload
development platform for developers’ space-based applications.

1.1 Features

= SAMD21 ARM Cortex-M0+ Microcontroller (Automotive Grade), 256kB Flash, 32kB SRAM, 48MHz
clock rate

= Single-Event-Latchup (SEL) protection: enabled by ZES100 Radiation-Hardened Latchup Detection
and Protection (LDAP).

= External non-volatile memory with SEU protection: 32kB FRAMs configured in TMR enabled by
ZES400 Radiation-Hardened Voters.

= Proprietary error-detection-and-correction (EDAC) C-code for detecting/correcting multiple errors
(SEUSs) within Flash/SRAM of the microcontroller.

* Common communication ports: Micro-USB, UART, SPI, I2C

= Single power source: 5V (/O voltage Interface @ 3.3V)

= Programing platform: C/C++ in Arduino-Compatible platform

= High Reliability Manufacturing (PCB Class IlI)

* Proton-tested up to 200MeV @ fluence > 101! particles/cm?

= TID test (to be available soon)

1.2 Block Diagram

Fig. 1 depicts the simplified diagram showing various key components and their interface
signals/connections. The primary inputs/outputs are shown in blue; their pin definitions are delineated in
Section 2.1 Table 1.

SWD Pins

Micro-USB
Reset ~33v
~3.3V {SCK, MOSI, nCS} 32kB FRAM_WP
ZES
VIN/5V oe/oC [ 10 ARM o > rrav +— FRAM Hold
501
Cortex- | o .
MO+ ZES 502 4> 32kB (€
33Ve—— Error 400 FRAM  &—
~3.3V MCU so3| Lsl
: EPITI
48MHz
Clock ( ) FRAM
32.768kHz MISO_EI

VTR_IN1, VTR_IN2, VTR_IN3
VTR_OUT, VTR_El

MCU Inputs/Outputs
{AREF, A0-A6, 0,1, ~2,
~3,~4,~5, 6,7, TX, RX,
ESCL, ESDA, MISO, SCK,

MOSI, PA21, 12C-SCL,

12C-SDA}

Fig. 1: The simplified block diagram of ZSOM™-M01

Please refer to the latest datasheet for the pin configuration and hardware setup.
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2 Basic User Guide to ZSOM-M01

The programming languages used are C++. For learning how to program/configure the SAMD21 ARM
Cortex-M0O+ microcontroller, please refer to the document associated with SAMD21G18A. To use this starter
kit, please contact info@zero-errorsystems.com to obtain the following example sketches.

(&) ExampleAccessFRAM.zip

2.1 Integrated Design Environment (IDE) Software Installation and Setup

e Download Arduino IDE from Arduino website.
Software | Arduino

DOWNLOAD OPTIONS
ArdUIrIO |DE 2.2.1 ‘Windows Win 10 and newer, 64 bits
Windows Ml installer
Windows 7IPfile
The new major release of the Arduino IDE is faster and even ) _
more powerful! In addition to a more modern editor and a Linux Appimage 64 bits (XB6-64}
mare responsive interface it features autocompletion, code Linux 2IP file 64 bits (XB6-64)

navigation, and even a live debugger.

macO$ Intel, 10.14: "Mojave” or newer, E4 hits

For more details, please refer to the Arduino IDE 2.0 macOS Apple Silicon, 11: "Big Sur” or newer, 64 bits

documentation. Releaze Notes

Nightly builds with the latest bugfixes are available through
the section below.
SOURCE CODE

The Arduino IDE 2.0 is open source and its source code is
hosted on GitHub.

¢ Install Arduino IDE and follow the installation instructions. (The installation might take several minutes
depending on your system’s performance.)

e Setup IDE and link it to a ZSOM™-MO01 board.

Connect the ZSOM™-MO0L1 to a PC.

Open Arduino IDE.

Go to "Tools" -> "Board"-> "Board Manager", look for "Arduino SAMD board" and install it.
Go to "Tools" -> "Board"-> "Arduino SAMD Boards (32-bits ARM Cortex-M0+)", select
"Arduino MKRZEROQO".

AL

File Edit Sketch Tools Help

Ao Sia _

~ Archive Sketch 3
Ais_Protg Data.ino
Manage Libraries. Ctrl+ Shifts
a8
232 Serial Monitor Ctri+Shift~M
99
100 Serial Plotter
101
, Firmware Updater
Output
Upload SSL Root Certificates

Board: "Arduino MKRZERO" »
Boards Manager Ctrl+Shift-B
Port: "COM3" »

® Arduino SAMD Boards (32-bits ARM Cortex-M0+) »
Arduino Zero (Programming Port)

Arduino Zero (Native USB Port)
Arduino MKR1000

v/ Arduino MKRZERO
Arduino MKR WiFi 1010
Arduino NANO 33 loT
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e Choose the appropriate COM port.
Go to "Tools" -> "Port", select the appropriate COM port.

File Edit Sketch Tools Help

AUto Format Ct’l+_ _

Archive Sketch

Ais_Protg Data.ino
Manage Libraries... Ctrl+Shift+l
:; Serial Menitor Cirl+ Shift=M
1;33 Serial Plotter
1641
Output Firmware Updater
Upload S5L Root Certificates
e Beoard: "Arduino MKRZERO" »
Port: "COM3"

Serial ports
Get Board Info
v COM3 (Arduino MKRZERO)

Programmer F

Burn Bootloader

2.2 Example Sketch from Arduino IDE

Before implementing sample sketch from ZES, users can explore one of the examples sketches available on
Arduino IDE to familiarize themselves with the board programming. In the section, the example sketch, Blink,
will be used.

e Go to “File” -> “Examples” -> “01.Basics” and click on “Blink” as shown below.

& Blink | Arduino IDE 2.3.2
File Edit Sketch Tools

01.Basics AnalogReadSerial
MNew Sketch
02.Digital BareMinimum

03.Analog Blink
Open... . . )
04.Communication DigitalReadSerial

Open Recent
05.Control Fade

Sketchbook

06.Sensors ReadAnalogVoltage

Examples

07.Displa

e Arduino IDE will be loaded with the program “Blink”.
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e Go to “Sketch” on Menu bar and click on “Verify/ Compile” or use hotkey “Ctrl+R” or click on the tick

symbol

File Edit Sketch Tools Help

Verify/Compile

Upload Using Programmer
Export Compiled Binary
Optimize for Debugging
Show Sketch Folder
Include Library

Add File...

e Next, go to “Sketch” on Menu bar again and click on “Upload” or use the hotkey “Ctrl+U” or click on

the right arrow key symbol

File Edit Sketch Tools Help
Verify/Compile

Upload

Upload Using Programmer
Export Compiled Binary
Optimize for Debugging
Show Sketch Folder
Include Library

Add File...

e Once the program has been uploaded successfully, the screen like below can be observed on the
“Output” log of the Arduino IDE. The LED on board can also be observed blinking.

Output
Write 11212 bytes to flash (176 pages)

36% (64/176 pages)

72% (128/176 pages)

100% (176/176 pages)
done in ©.€93 seconds

Verify 11212 bytes of flash with checksum.
Verify successful

done in ©.01@ seconds

CPU reset.
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e By default, the LED blink time or on-off time is defined by the code below in the program and the
time is 1 second or 1000 millisecond. The LED will be on for 1 sec and off for 1 sec. Then, the
blinking will repeat infinitely since it is in a loop.

e Next, change the LED blinking time by changing the delay time from 1000 to 100. The code should
look like below to indicate the delay is 100ms. It can be observed that the LED is blinking faster than
earlier.

digitalWrite(LED BUILTIN, HIGH);

e Users can also try out other examples available in the Arduino IDE. However, some of them will
require extra components or equipment to test or observe.

2.3 Sample Sketch to Access FRAM within ZSOM™-M01

o Please refer to “ExampleAccessFRAM.zip”.

¢ Run “ExampleAccessFRAM.ino” in Arduino IDE after unzip ping the file.

e Make sure serial port is turn ON. [From Arduino IDE, press Ctrl + Shift + M]
e Upload sketch into ZSOM™-MO01 board. [From Arduino IDE, press Ctrl + U]

e Follow instructions from “FRAM Menu” to test FRAM.

Serial port initialize done.
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3 ZES Error Detection and Correction (ZEDAC) Protection

The programming languages used are C/C++. For learning how to program/configure the SAMD21 ARM
Cortex-M0O+ microcontroller, please refer to the document associated with SAMD21G18A. To use this starter
kit, please contact info@zero-errorsystems.com to obtain the following library and example sketches.

(a) zeseDAC_1k_A_verl.3.0.zip (ZEDAC library)
(b) ExampleZEDACUsage.zip

3.1 ZEDAC Library Download and Installation
a. “zeseDAC_1k_A verl.3.0.zip” is the ZEDAC library.

b. Add "zesEDACV130" library.
Go to "Sketch" -> "Include Library" -> "Add .ZIP Library...",
Go to folder where the ZEDAC library file is stored, select the library file.

File Edit Sketch Tools Help

E fer/omele o -

Upload Ctrl+U
i Configure and Upload

Upload Using Pregrammer Ctrl+5Shift=U

Export Compiled Binary Alt+Ctrl+5

Optimize for Debugging

Show Sketch Folder Alt+Ctrl+K
Include Library
Manage Libraries.., Ctrl+Shift+|
Add File...
18 Add ZIP Library..

Arduino libraries

HID

c. Check if the library file is installed successfully.
Go to "Sketch" -> "Include Library", now "zesEDAC130" should be found under "Contributed
libraries" section.

Show Sketch Folder Alt=Ctrl+K
Include Library Lo Manage Libraries..  Ctrl+5hift=]
& Bxamp  Add File.. Add ZIP Library..

File Edit ools Help Contributed libraries
o e Select Board FlashStorage

FlashStorage_5TM32

ExampleEDACUsage.ino  Edac_Ctrlh  Ed
) 5D
: Timerlnterrupt

zesEDACT30

d. If the library is installed successfully, “zesEDACV130.h” can be found at
“..\libraries\zeseEDAC130\src”
Remember to include “zesEDACV130.h” to sketch to use ZEDAC.
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3.2 Sample Sketch to Use ZEDAC within ZSOM-MO01

e Make sure ZSOM-MO1 is connected to system.
e Choose the appropriate COM port.
Go to "Tools" -> "Pont", select the appropriate COM port.
e Please refer to “ExampleZEDACUsage.zip”.
e Run “ExampleZEDACUsage.ino” in Arduino IDE after unzip ping the file.
e Make sure a serial port is turn ON. [From Arduino IDE, press Ctrl + Shift + M]
e Upload the sketch into ZSOM™-MO01 board. [From Arduino IDE, press Ctrl + U]

e Follow instructions from “EDAC Test Menu” to test ZEDAC.

S WD W

L=l

momomom o
P

w2
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4 Revision History

Version Description Date
V1.1 Update ZEDAC version (zesEDACV1.3.0). 21-Aug-2024
V1.0 First version 07-Mar-2024

For the latest version of this document, please contact us info@zero-errorsystems.com.

5 Legal

All products, product specificatios and data are subject to change without notice.
IMPORTANT NOTICE AND DISCLAIMER

ZES PROVIDES TECHNICAL AND RELIABILITY DATA (INCLUDING DATA SHEETS), DESIGN
RESOURCES (INCLUDING REFERENCE DESIGNS), APPLICATION OR OTHER DESIGN ADVICE, AND
OTHER RESOURCES “AS IS” AND WITH ALL FAULTS, AND DISCLAIMS ALL WARRANTIES, EXPRESS
AND IMPLIED, INCLUDING WITHOUT LIMITATION ANY IMPLIED WARRANTIES OF
MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE OR NON-INFRINGEMENT OF THIRD
PARTY INTELLECTUAL PROPERTY RIGHTS.

These resources are intended for skilled developers designing with ZES products. You are solely
responsible for (1) selecting the appropriate ZES products for your application, (2) designing,
validating and testing your application, and (3) ensuring your application meets applicable
standards, and any other safety, security, regulatory or other requirements.

These resources are subject to change without notice. ZES grants you permission to use these
resources only for development of an application that uses the ZES products described in the
resource. Other reproduction and display of these resources is prohibited. No license is granted to
any other ZES intellectual property right or to any third-party intellectual property right. ZES
disclaims responsibility for, and you will fully indemnify ZES and its representatives against, any
claims, damages, costs, losses, and liabilities arising out of your use of these resources.

ZES’ products are provided subject to ZES’ Terms of Sale or other applicable terms available
either on zero-errorsystems.com or provided in conjunction with such ZES products. ZES’
provision of these resources does not expand or otherwise alter ZES’ applicable warranties or
warranty disclaimers for ZES products. ZES objects to and rejects any additional or different terms
you may have proposed.

Copyright © 2022, Zero-Error Systems Pte. Ltd.
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